Note: The other languages of the website are Google-translated. Back to English

Jak policzyć liczbę odpowiedzi „Tak” lub „Nie” w programie Excel?

Na przykład masz arkusz z „Tak”, „Nie” lub innymi odpowiedziami i chcesz policzyć procent tych odpowiedzi jeden po drugim. Zanim policzysz procent odpowiedzi, musisz znać całkowitą liczbę komórek „Tak”, „Nie” lub innych odpowiedzi oddzielnie. W tym artykule pokażemy, jak policzyć liczbę komórek „Tak” lub „Nie” w programie Excel.

Policz liczbę „Tak” lub „Nie” za pomocą funkcji CountIf
Szybko policz i wybierz liczbę komórek wartości „Tak” lub „Nie” za pomocą niesamowitego narzędzia


Policz liczbę „Tak” lub „Nie” za pomocą funkcji CountIf

Na przykład masz odpowiedzi w zakresie komórek „B15: B21”, a formuła funkcji CountIf pozwala policzyć liczbę odpowiedzi „Tak” lub „Nie” w następujący sposób.

Policz liczbę „Tak”

1. Wybierz pustą komórkę, skopiuj i wklej wzór =LICZ.JEŻELI(B15:B21;"Tak") na pasku formuły, a następnie naciśnij klawisz Enter. Następnie możesz zobaczyć wynik wyświetlania w wybranej komórce. Zobacz zrzut ekranu:

Policz liczbę „Nie”

1. Wybierz pustą komórkę, skopiuj i wklej formułę = LICZ.JEŻELI (B15: B21; „Nie”) do paska formuły, a następnie naciśnij klawisz Enter.

Policz inną odpowiedź

Na przykład, jeśli jest odpowiedź „Neutralność”Pomieszać Tak i Nie, możesz to również policzyć za pomocą funkcji CountIf.

1. Wybierz pustą komórkę, skopiuj i wklej formułę =COUNTA(B15:B21)-COUNTIF(B15:B21,"Yes")-COUNTIF(B15:B21,"No")-COUNTIF(B15:B21,"=""") do paska formuły, a następnie naciśnij klawisz Enter. Otrzymasz liczbę innych odpowiedzi oprócz „Tak” i „Nie”, patrz zrzut ekranu:

Uwagi: Po skopiowaniu i wklejeniu powyższych formuł musisz zmienić zakres komórek na podstawie arkusza.


Szybko policz i wybierz liczbę komórek wartości „Tak” lub „Nie” za pomocą niesamowitego narzędzia

YMożesz szybko policzyć i zaznaczyć komórki za pomocą „Tak”, „Nie” lub innych odpowiedzi w następujący sposób.

Przed złożeniem wniosku Kutools dla programu ExcelProszę pobierz i zainstaluj najpierw.

1. Proszę kliknąć Kutools > Wybierz > Wybierz określone komórki.

2. w Wybierz określone komórki W oknie dialogowym wybierz zakres komórek w Wybierz komórki w tym zakresie Sekcja, wybierz Komórka opcję w sekcji Typ wyboru określ równe i Tak (lub Nie i inne) w Określony typ i na koniec kliknij Ok przycisk. Zobacz zrzut ekranu poniżej.

3. Następnie możesz zobaczyć, że całkowita liczba komórek Tak jest wyświetlana w pliku Wybierz określone komórki okno dialogowe, a następnie kliknij plik OK przycisk.

Po kliknięciu OK przycisk, wszystkie komórki z tak w wybranym zakresie komórek są wybierane automatycznie.

Możesz powtórzyć powyższe kroki, aby policzyć komórki z odpowiedziami Nie lub innymi.

  Jeśli chcesz skorzystać z bezpłatnego okresu próbnego (30-dzień) tego narzędzia, kliknij, aby go pobrać, a następnie przejdź do wykonania operacji zgodnie z powyższymi krokami.


Policz liczbę „Tak” lub „Nie” za pomocą Kutools for Excel


Podobne artykuły:


Najlepsze narzędzia biurowe

Kutools dla programu Excel rozwiązuje większość problemów i zwiększa produktywność o 80%

  • Ponowne użycie: Szybko włóż złożone wzory, wykresy i wszystko, czego używałeś wcześniej; Szyfruj komórki z hasłem; Utwórz listę mailingową i wysyłaj e-maile ...
  • Pasek Super Formula (łatwo edytować wiele wierszy tekstu i formuły); Układ do czytania (łatwe odczytywanie i edytowanie dużej liczby komórek); Wklej do filtrowanego zakresu...
  • Scal komórki / wiersze / kolumny bez utraty danych; Podziel zawartość komórek; Połącz zduplikowane wiersze / kolumny... Zapobiegaj zduplikowanym komórkom; Porównaj zakresy...
  • Wybierz Duplikat lub Unikalny Wydziwianie; Wybierz puste wiersze (wszystkie komórki są puste); Super Find i Fuzzy Find w wielu zeszytach ćwiczeń; Losowy wybór ...
  • Dokładna kopia Wiele komórek bez zmiany odwołania do formuły; Automatyczne tworzenie odniesień do wielu arkuszy; Wstaw punktory, Pola wyboru i nie tylko ...
  • Wyodrębnij tekst, Dodaj tekst, Usuń według pozycji, Usuń przestrzeń; Tworzenie i drukowanie podsumowań stronicowania; Konwertuj zawartość komórek i komentarze...
  • Super filtr (zapisz i zastosuj schematy filtrów do innych arkuszy); Zaawansowane sortowanie według miesiąca / tygodnia / dnia, częstotliwości i innych; Specjalny filtr pogrubieniem, kursywą ...
  • Połącz skoroszyty i arkusze robocze; Scal tabele na podstawie kluczowych kolumn; Podziel dane na wiele arkuszy; Konwersja wsadowa xls, xlsx i PDF...
  • Ponad 300 zaawansowanych funkcji. Obsługuje Office / Excel 2007-2021 i 365. Obsługuje wszystkie języki. Łatwe wdrażanie w przedsiębiorstwie lub organizacji. Pełne funkcje 30-dniowa bezpłatna wersja próbna. 60-dniowa gwarancja zwrotu pieniędzy.
karta kte 201905

Karta Office wprowadza interfejs z zakładkami do pakietu Office i znacznie ułatwia pracę

  • Włącz edycję i czytanie na kartach w programach Word, Excel, PowerPoint, Publisher, Access, Visio i Project.
  • Otwieraj i twórz wiele dokumentów w nowych kartach tego samego okna, a nie w nowych oknach.
  • Zwiększa produktywność o 50% i redukuje setki kliknięć myszką każdego dnia!
officetab dół
Sortuj komentarze według
Komentarze (4)
Brak ocen. Oceń jako pierwszy!
Ten komentarz został zminimalizowany przez moderatora na stronie
trzeba dodać do tego liczbę spacji
Ten komentarz został zminimalizowany przez moderatora na stronie
bardzo pomocne, proste i pouczające, wielkie dzięki!
Ten komentarz został zminimalizowany przez moderatora na stronie
Dziękuję Ci!...
Ten komentarz został zminimalizowany przez moderatora na stronie
Powinien być ; zamiast , w =LICZ.JEŻELI(B15:B21,"Nie") przynajmniej w programie Excel w wersji 2205
Nie ma tu jeszcze żadnych komentarzy
Zostaw swój komentarz
Publikowanie jako gość
×
Oceń ten post:
0   Postacie
Sugerowane lokalizacje

Bądż na bieżąco

Prawa autorskie © 2009 - www.extendoffice.com. | Wszelkie prawa zastrzeżone. Zasilany przez ExtendOffice, | Mapa strony
Microsoft i logo Office są znakami towarowymi lub zastrzeżonymi znakami towarowymi Microsoft Corporation w Stanach Zjednoczonych i / lub innych krajach.
Chronione przez Sectigo SSL