Note: The other languages of the website are Google-translated. Back to English

Jak znaleźć wartość w komórce z listą oddzieloną przecinkami w programie Excel?

Przypuśćmy, że masz kolumnę zawierającą wartości oddzielone przecinkami, takie jak Sales, 123, AAA, a teraz chcesz sprawdzić, czy wartość 123 w komórce oddzielonej przecinkami, jak możesz to zrobić? Ten artykuł przedstawi metodę rozwiązania problemu.

Znajdź wartość w komórce z listą oddzieloną przecinkami i formułą


Znajdź wartość w komórce z listą oddzieloną przecinkami i formułą

Poniższa formuła może pomóc w znalezieniu wartości w komórce z listą oddzieloną przecinkami w programie Excel. Wykonaj następujące czynności.

1. Wybierz pustą komórkę, wprowadź formułę =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") do paska formuły, a następnie naciśnij klawisz Enter. Zobacz zrzut ekranu:

Uwagi: we wzorze A2 to komórka zawierająca wartości oddzielone przecinkami, które znajdziesz.

2. Kontynuuj wybieranie komórki wynikowej i przeciągnij uchwyt wypełnienia w dół, aby uzyskać wszystkie wyniki. Jeśli wartość „123” znajduje się w komórkach oddzielonych przecinkami, wynik zostanie wyświetlony jako „Tak”; w przeciwnym razie jako wynik otrzymasz „Nie”. Zobacz zrzut ekranu:


Podobne artykuły:


Najlepsze narzędzia biurowe

Kutools dla programu Excel rozwiązuje większość problemów i zwiększa produktywność o 80%

  • Ponowne użycie: Szybko włóż złożone wzory, wykresy i wszystko, czego używałeś wcześniej; Szyfruj komórki z hasłem; Utwórz listę mailingową i wysyłaj e-maile ...
  • Pasek Super Formula (łatwo edytować wiele wierszy tekstu i formuły); Układ do czytania (łatwe odczytywanie i edytowanie dużej liczby komórek); Wklej do filtrowanego zakresu...
  • Scal komórki / wiersze / kolumny bez utraty danych; Podziel zawartość komórek; Połącz zduplikowane wiersze / kolumny... Zapobiegaj zduplikowanym komórkom; Porównaj zakresy...
  • Wybierz Duplikat lub Unikalny Wydziwianie; Wybierz puste wiersze (wszystkie komórki są puste); Super Find i Fuzzy Find w wielu zeszytach ćwiczeń; Losowy wybór ...
  • Dokładna kopia Wiele komórek bez zmiany odwołania do formuły; Automatyczne tworzenie odniesień do wielu arkuszy; Wstaw punktory, Pola wyboru i nie tylko ...
  • Wyodrębnij tekst, Dodaj tekst, Usuń według pozycji, Usuń przestrzeń; Tworzenie i drukowanie podsumowań stronicowania; Konwertuj zawartość komórek i komentarze...
  • Super filtr (zapisz i zastosuj schematy filtrów do innych arkuszy); Zaawansowane sortowanie według miesiąca / tygodnia / dnia, częstotliwości i innych; Specjalny filtr pogrubieniem, kursywą ...
  • Połącz skoroszyty i arkusze robocze; Scal tabele na podstawie kluczowych kolumn; Podziel dane na wiele arkuszy; Konwersja wsadowa xls, xlsx i PDF...
  • Ponad 300 zaawansowanych funkcji. Obsługuje Office / Excel 2007-2021 i 365. Obsługuje wszystkie języki. Łatwe wdrażanie w przedsiębiorstwie lub organizacji. Pełne funkcje 30-dniowa bezpłatna wersja próbna. 60-dniowa gwarancja zwrotu pieniędzy.
karta kte 201905

Karta Office wprowadza interfejs z zakładkami do pakietu Office i znacznie ułatwia pracę

  • Włącz edycję i czytanie na kartach w programach Word, Excel, PowerPoint, Publisher, Access, Visio i Project.
  • Otwieraj i twórz wiele dokumentów w nowych kartach tego samego okna, a nie w nowych oknach.
  • Zwiększa produktywność o 50% i redukuje setki kliknięć myszką każdego dnia!
officetab dół
Sortuj komentarze według
Komentarze (16)
Brak ocen. Oceń jako pierwszy!
Ten komentarz został zminimalizowany przez moderatora na stronie
Dzień dobry wszystkim. Mam pytanie w programie Excel, jak policzyć określone wartości oddzielone przecinkami w jednej komórce w programie Excel. Chcę policzyć nie z 15 w jednej komórce zawierającej 15,215,15,155,45,1515,15 Potrzebuję wynik 3. Czy istnieje jakaś formuła w programie Excel.
Ten komentarz został zminimalizowany przez moderatora na stronie
Tak, w programie Excel jest funkcja, która może to zrobić za Ciebie. Jednak, jak wyjaśniono w powyższym problemie, aby uzyskać większą dokładność danych, dodaj przecinek po lewej i prawej stronie listy i uwzględnij go w wyszukiwaniu. Zobacz przykład poniżej:
, 15,215,15,155,45,1515,15,
=LICZ.JEŻELI(A1;";15;")
Wyjaśnienie tej formuły jest następujące: = LICZ.JEŻELI (numer lub zakres komórek, wartość, której szukasz/liczysz)
Daj mi znać, jeśli potrzebujesz lepszego przykładu.
Ten komentarz został zminimalizowany przez moderatora na stronie
Witaj!
To naprawdę fajna formuła, ale ma… wadę? ... że nie mogę wymyślić, jak to obejść. „Wada” nie jest właściwym słowem, ale nie potrafię wymyślić właściwego słowa (jest 8:30 w poniedziałek).
Kiedy szukasz jakiejkolwiek części numeru, otrzymujesz „tak”. Tak więc wszystkie następujące zwracają „tak”:
=JEŻELI(CZY.LICZBA(SZUKAJ(12;A2));"tak","nie")
=JEŻELI(CZY.LICZBA(SZUKAJ(23;A2));"tak","nie")
=JEŻELI(CZY.LICZBA(SZUKAJ(3;A2));"tak","nie")

Próbowałem owijać liczby w cudzysłów, ale bezskutecznie. Formuła sprawdza się doskonale w przypadku użycia z przykładu, w którym wszystkie liczby mają tę samą długość. Ale jeśli szukasz krótszej liczby, która pojawia się w łańcuchu, otrzymasz fałszywie dodatni wynik.
Czy istnieje alternatywa dla „SZUKAJ”, która jest bardziej dosłowna (ponownie, czy to słowo? haha)? 
Dzięki! 
Ten komentarz został zminimalizowany przez moderatora na stronie
Cześć Scott S., Masz na myśli wyszukiwanie dokładnego ciągu znaków?
Ten komentarz został zminimalizowany przez moderatora na stronie
Cześć Kryształowo.
Tak, przypuszczam, że to jest sposób na wyrażenie tego. 
Bieżące rozwiązanie zwróci „Tak” dla dowolnej części ciągu liczbowego. Tak więc liczby 1, 2, 3, 12, 23 i 123 zwrócą „Tak”. 
Próbowałem wymyślić rozwiązanie, które przeszuka ciąg liczb i zwróci „Tak” dla dokładnego dopasowania. 
Ten komentarz został zminimalizowany przez moderatora na stronie
Cześć Scott S, dziękuję za twoją opinię. Nie znalazłem jeszcze rozwiązania i skontaktuję się z Tobą, jeśli je znajdę.
Ten komentarz został zminimalizowany przez moderatora na stronie
Znalazłem na to rozwiązanie. Jeśli dodasz przecinek po lewej i prawej stronie listy i uwzględnisz je (jak kanapkę) w wyszukiwaniu, pozwoli Ci to znaleźć dokładne dopasowanie. Przykład poniżej:
, 123,231,321,122,321,1,2,3,23,
SZUKAJ(",23,")
W ten sposób zmusza wyszukiwanie do dopasowania od jednego przecinka do drugiego, a nie tylko części wpisu z listy. Mam nadzieję, że tego właśnie szukałeś?
Ten komentarz został zminimalizowany przez moderatora na stronie
Znalazłem rozwiązanie. Jeśli dodasz przecinek po lewej i prawej stronie listy, funkcja wyszukiwania będzie wymagała znalezienia dokładnego dopasowania od przecinka do przecinka. Zobacz przykład poniżej:
=JEŻELI(CZY.LICZBA(SZUKAJ(;12;;A2));"tak","nie")

, 312,123,10,112,126,
To zwróci false, ponieważ nie ma zmiennej od przecinka do przecinka (,12,), która pasuje do wyszukiwania. 
Jeśli potrzebujesz dalszych wyjaśnień, daj mi znać, a ja zamieszczę lepszy przykład. Miałem ten sam problem podczas automatyzowania raportu dla mojego szefa i doznałem objawienia. :)
Ten komentarz został zminimalizowany przez moderatora na stronie
Hej, nadal nie mogę tego rozgryźć. Nadal mam ten sam problem. zamiast używać liczby w formule, używam odwołania do komórki. na przykład, jeśli szukam „1” (Q $ 1) w (123, 25,29,200) ($ J2), nadal daje mi TAK. Formuła to =JEŻELI(CZY.LICZBA(SZUKAJ(Q$1;$J2));"tak","nie")

PS: Mam duży zestaw danych, nie mogę wstawić przecinków przed i po w każdej komórce. Docenię rozwiązanie
Ten komentarz został zminimalizowany przez moderatora na stronie
Witam Proszę o pomoc

Mam tabelę w Excelu z dwiema kolumnami A i B, pod A są wartości Np. komórka A2 ma 1,2,2,1,2,1,2 itd. (ma tylko dwie liczby 1 i 2, ale musi rozpoznać, że ma tylko 1 i 2 w całej komórce i żadnej innej liczby), a A3 ma 1,1,1 a A4 ma 0, A5 ma 2,2,2,2 a A6 ma 20. Chcę, aby B2 zwróciło wartość dla A2 jako Asia , B3 Afryka, B4 jako Brak, B5 jako Ameryka i B6 jako Europa. Pomyślałem, że mógłbym użyć formuły if, ale nie jest ona w stanie rozpoznać liczb oddzielonych przecinkami i wartości zwracanej). Proszę pomóż
Ten komentarz został zminimalizowany przez moderatora na stronie
Co powiesz na to, proszę, muszę uzyskać wartości w A i zrównać je z liczbami w C i zwrócić wartości w B oddzielone przecinkami odpowiednio do C.

Podziękowania
Ten komentarz został zminimalizowany przez moderatora na stronie
Cześć Duncan,
Jeśli korzystasz z programu Excel dla 365, poniższa formuła może pomóc w rozwiązaniu problemu.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Ta formuła działa tylko w programie Excel dla 365. W przypadku innych wersji programu Excel innych niż Excel dla 365 nie znalazłem formuły, która ją obsługuje..
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Ten komentarz został zminimalizowany przez moderatora na stronie
Cześć wszystkim, mam komórkę, która zawiera wiele krajów oddzielonych przecinkami
Przykład: wartość komórki A2 to (Indie, Japonia, Malezja, Wielkie Chiny)
Kolumna G zawiera nazwy krajów
Teraz muszę znaleźć szukać formuły, która porównuje wartość z kolumny G do wartości w komórce A2.
Jeśli wartość jest zgodna, zwróć wartość true, w przeciwnym razie zwróć wartość False
Ten komentarz został zminimalizowany przez moderatora na stronie
Witaj Mohini Verma,
Formułę można zmodyfikować w następujący sposób:
=JEŻELI(CZY.LICZBA(SZUKAJ(G2;A2));"PRAWDA","FAŁSZ")
Ten komentarz został zminimalizowany przez moderatora na stronie
Hej, nadal nie mogę tego rozgryźć. Nadal mam ten sam problem. zamiast używać liczby w formule, używam odwołania do komórki. na przykład, jeśli szukam „1” (Q $ 1) w (123, 25,29,200) ($ J2), nadal daje mi TAK. Formuła to =JEŻELI(CZY.LICZBA(SZUKAJ(Q$1;$J2));"tak","nie")

PS: Mam duży zestaw danych, nie mogę wstawić przecinków przed i po w każdej komórce. Docenię rozwiązanie
Ten komentarz został zminimalizowany przez moderatora na stronie
Cześć Hassam

Po prostu użyj następującego wzoru bez funkcji JEŻELI. Jeśli liczba pasuje dokładnie, otrzymasz wynik "TRUE", w przeciwnym razie otrzymasz wynik"FAŁSZYWY".
=CZY.LICZBA(ZNAJDŹ(",1,"","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Nie ma tu jeszcze żadnych komentarzy
Zostaw swój komentarz
Publikowanie jako gość
×
Oceń ten post:
0   Postacie
Sugerowane lokalizacje

Bądż na bieżąco

Prawa autorskie © 2009 - www.extendoffice.com. | Wszelkie prawa zastrzeżone. Zasilany przez ExtendOffice, | Mapa strony
Microsoft i logo Office są znakami towarowymi lub zastrzeżonymi znakami towarowymi Microsoft Corporation w Stanach Zjednoczonych i / lub innych krajach.
Chronione przez Sectigo SSL