Note: The other languages of the website are Google-translated. Back to English
Zaloguj Się  \/ 
x
or
x
Rejestruję się  \/ 
x

or

Funkcja EXCEL LICZ.JEŻELI - Policz komórki, które nie są puste, większe/mniejsze niż lub zawierają określoną wartość

Podczas pracy z arkuszem programu Excel liczenie liczby komórek, na przykład liczenie pustych lub niepustych komórek, komórek większych lub mniejszych niż podana wartość lub komórek zawierających określony tekst, może być typowymi zadaniami dla większości nas. Aby poradzić sobie z tymi obliczeniami, funkcja LICZBA w programie Excel może wyświadczyć Ci przysługę.

Składnia funkcji LICZ.JEŻELI w programie Excel

LICZ.JEŻELI funkcja dla pustych lub niepustych komórek

LICZ.JEŻELI funkcja dla komórek mniejszych niż, większych lub równych określonej wartości

LICZ.JEŻELI funkcja dla komórek zawiera określoną wartość


Składnia funkcji LICZ.JEŻELI w programie Excel

Jako jedna z funkcji statystycznych w programie Excel LICZ.JEŻELI zlicza komórki spełniające podane kryteria w określonym zakresie. Składnia funkcji LICZ.JEŻELI to:

=COUNTIF(range, criteria)

Składnia zawiera dwa argumenty – zasięg dzięki Kryteria:

  • zasięg: odnosi się do zakresu komórek, które chcesz policzyć.
  • Kryteria: odnosi się do warunku, którego chcesz użyć do zliczania komórek. Na przykład możesz użyć „>=80” jako kryterium, aby wyszukać komórki z wartościami większymi lub równymi 80 w wybranym zakresie.

Aby zastosować funkcję w Excelu, należy wpisać = LICZ.JEŻELI (zakres, kryteria) w komórce docelowej. Na przykład, =LICZ.JEŻELI(A1:B8;">=80").

Funkcja LICZ.JEŻELI zwraca wartość liczbową — liczbę komórek, które chcesz policzyć.

Teraz, gdy lepiej rozumiemy funkcję LICZ.JEŻELI, przejdźmy do kilku prawdziwych przykładów.


LICZ.JEŻELI funkcja dla pustych lub niepustych komórek

Na przykład mam listę komórek, które zawierają różne typy danych, takie jak tekst, wartości logiczne (PRAWDA i FAŁSZ), liczby, daty i błędy. Czy istnieje uniwersalna formuła LICZ.JEŻELI do zliczania tylko pustych lub niepustych komórek, bez względu na to, jakie typy danych istnieją w określonym zakresie?

liczyć puste mniej 1

Policz puste komórki za pomocą funkcji LICZ.JEŻELI

Teraz pozwól, że przedstawię Ci formułę LICZ.JEŻELI. Formuła, bez względu na to, ile typów danych znajduje się w zakresie, poda dokładną i poprawną liczbę pustych komórek:

=COUNTIF(range,"")
Uwaga: W cudzysłowie nie ma tekstu, co oznacza, że ​​komórki, które chcesz policzyć, są puste.

Aby użyć funkcji LICZ.JEŻELI do zliczania pustych komórek, wpisz formułę =LICZ.JEŻELI(A1:A9;"") w komórce docelowej, a następnie naciśnij ENTER:

liczyć puste mniej 2 >>> liczyć puste mniej 3

W programie Excel istnieje również funkcja o nazwie LICZ.PUSTE, który zwraca liczbę pustych komórek w określonym zakresie. Jego składnia to = COUNTBLANK (zakres). W powyższym przykładzie możesz użyć formuły: =LICZ.PUSTE(A1:A9).


Policz niepuste komórki za pomocą funkcji LICZ.JEŻELI

Aby policzyć komórki, które nie są puste, pokażę ci formułę:

=COUNTIF(range,"<>")
Uwaga: <> w Excelu oznacza nie równa się. Tak więc powyższa formuła zlicza wszystkie komórki, które nie są puste, lub możemy powiedzieć, że nie są puste.

Aby użyć funkcji LICZ.JEŻELI do zliczenia komórek, które nie są puste, wpisz formułę =LICZ.JEŻELI(A1:A9;"<>") w komórce docelowej, a następnie naciśnij ENTER:

liczyć puste mniej 4 >>> liczyć puste mniej 5

W programie Excel istnieje również funkcja o nazwie COUNTA, który zwraca liczbę komórek zawierających dowolne wartości z określonego zakresu. Jego składnia to =ILE.LICZB(zakres). W powyższym przykładzie możesz użyć formuły: = COUNTA (A1: A9).

Jeśli jednak chcesz liczyć tylko komórki zawierające tylko tekst i wykluczyć wartości logiczne (PRAWDA i FAŁSZ), liczby, daty lub błędy, użyj poniższej formuły:

=COUNTIF(A1:A9,"*")
Note: A single asterisk (*) matches only the value in a text form.

liczyć puste mniej 6 >>> liczyć puste mniej 7

Policz niepuste komórki za pomocą dwóch kliknięć

Jeśli have Kutools dla programu Excel zainstalowany w twoim Excelu, z jego Wybierz niepuste komórki funkcja, możesz wybrać wszystkie niepuste komórki naraz i uzyskać numer zgodnie z potrzebami.

1. Możesz przejść do Kutools zakładka w Excelu, znajdź Wybierzi kliknij Wybierz niepuste komórki na liście rozwijanej. Zobacz zrzut ekranu:

liczyć puste mniej 8

2. Zostaną wybrane wszystkie niepuste komórki, a pojawi się okno z informacją o liczbie niepustych komórek, jak pokazano na poniższym zrzucie ekranu:

liczyć puste mniej 9

Kliknij, aby pobrać Kutools for Excel na 30-dniową bezpłatną wersję próbną.


LICZ.JEŻELI funkcja dla komórek mniejszych niż, większych lub równych określonej wartości

W tym miejscu wymieniliśmy dwie główne metody liczenia komórek o wartościach mniejszych, większych, równych lub nierównych określonej wartości w programie Excel.

LICZ.JEŻELI mniejsze niż, większe niż, równe lub nierówne z formułami

Aby użyć formuły do ​​zliczania komórek o wartościach mniejszych, większych, równych lub nierównych określonej wartości, należy dobrze wykorzystać Operatory porównania (<, >, =, ).

Uwagi: Metody można również użyć do zliczania komórek z datami, które są przed (mniejsze niż <), po (większe niż >) lub równe (=) określonej dacie.

Teraz spójrzmy na kilka prawdziwych przykładów zgodnie z poniższą tabelą:

liczyć puste mniej 10

Aby policzyć liczbę uczniów, których łączny wynik wynosi ponad (>) 140, użyj wzoru:
=LICZ.JEŻELI(E2:E8;">140") >>> Wynik to 5
Aby policzyć liczbę uczniów, których wynik z matematyki wynosi niższa niż (<) wynik Coco (wartość w komórce D3), użyj wzoru:
=LICZ.JEŻELI(D2:D8;"<"&D3) >>> Wynik to 2
Uwaga: Aby użyć odwołania do komórki w funkcji LICZ.JEŻELI z operatorami porównania, musisz umieścić operatory w cudzysłowie i dodać znak ampersand (&) przed odwołaniem do komórki.
Aby policzyć liczbę uczniów, których wynik z języka angielskiego wynosi większe lub równe (≥) wynik Eddiego (wartość w komórce C4), użyj wzoru:
=COUNTIF(C2:C8,">="&C4)-1 >>> The result is 5
Uwaga: Powodem odjęcia 1 jest to, że kryteria C2:C8,">="&C4 poproś LICZ.JEŻELI, aby policzyć wszystkie pasujące komórki, w tym tę z wynikiem angielskim Eddiego, więc musimy ją odjąć od formuły. Jeśli chcesz liczyć Eddiego, usuń „-1” z formuły.
Aby policzyć liczbę studentów, którzy: pochodzą z (=) Indie, użyj wzoru:
=LICZ.JEŻELI(B2:B8;"Indie") OR =LICZ.JEŻELI(B2:B8;B2) >>> Wynik to 3
Uwaga: wartość w odwołaniu do komórki B2 to Indie, więc "Indie" dzięki B2 obydwa w porządku działają jako kryteria tutaj. W funkcji LICZ.JEŻELI kryteria to wielkość liter nie jest rozróżniana. Tak więc ciągi „Indie” i „INDIA” nie będą miały wpływu na wynik formuły.
Aby policzyć liczbę studentów, którzy: nie pochodzą z (≠) Indii, użyj wzoru:
=LICZ.JEŻELI(B2:B8;"<>Indie") OR =LICZ.JEŻELI(B2:B8;"<>"&B2) >>> Wynik to 4

Funkcja LICZ.JEŻELI działa tylko wtedy, gdy istnieje jeden warunek, w przypadku większej liczby warunków należy użyć funkcji LICZ.JEŻELI. Na przykład, aby policzyć uczniów, których wynik z języka angielskiego wynosi od 60 do 90 (>60, <90), użyj wzoru: =COUNTIFS(B2:B8,">60",B2:B8,"<90").
Kliknij, aby dowiedzieć się więcej o funkcji LICZ.WARUNKI…


LICZ.JEŻELI mniejsze niż, większe niż, równe lub nierówne przy kilku kliknięciach

Aby zliczyć komórki z wartościami mniejszymi, większymi, równymi lub nierównymi określonej wartości w wygodniejszy sposób, można zastosować Wybierz określone komórki funkcjaf Kutools dla programu Excel.

Po zainstalowaniu Kutools dla programu Excel wykonaj następujące czynności:

1. Proszę znaleźć Kutools tab, a następnie przejdź do Wybierzi kliknij Wybierz określone komórki na liście rozwijanej.

liczyć puste mniej 11

2. Teraz zobaczysz wyskakujące okienko, wykonaj następujące czynności:

liczyć puste mniej 11

Poniżej znajduje się przykład liczenia uczniów, których wynik z matematyki wynosi niższa niż (<) wynik Coco z Kutools.

liczyć puste mniej 11

Uwaga: Program zwróci wynik zliczania i wybierze komórkę (komórki) spełniające kryteria. Możesz je skopiować, jeśli potrzebujesz.

Kliknij, aby pobrać Kutools for Excel na 30-dniową bezpłatną wersję próbną.


LICZ.JEŻELI funkcja dla komórek zawiera określoną wartość

Aby użyć LICZ.JEŻELI do zliczenia komórek zawierających określoną wartość (na przykład komórek z literą Y), a nawet do zliczenia komórek o określonej wartości w określonej pozycji (na przykład komórki zaczynają się na literę Y), możemy musisz wiedzieć o znakach wieloznacznych.

Istnieją trzy symbole wieloznaczne — gwiazdka (*), pytanie znak (?), A tylda (~) dostępne w programie Excel dla funkcji LICZ.JEŻELI:

Gwiazdka (*) — pasuje do dowolnej liczby znaków. Na przykład *ice może oznaczać miło, serwis, lód, @#$ice itp.
Znak zapytania (?) — dopasowuje dowolny znak. Na przykład mo?? może oznaczać więcej, księżyc, miesiąc i %, moaa itp.
Tylda (~) — pasuje do rzeczywistego znaku wieloznacznego. Na przykład ~* oznacza dosłowny znak gwiazdki, ~~ oznacza dosłowną tyldę.

Uwaga: Wartości logiczne (PRAWDA i FAŁSZ), liczby, daty i błędy nie są liczone jako znaki. Jeśli więc w wybranym zakresie komórek znajdują się powyższe elementy, będziesz musiał przekonwertować je na tekst.

Więcej informacji:
Jak zmienić lub przekonwertować numer na tekst w programie Excel?
Jak przekonwertować datę na ciąg liczbowy lub format tekstowy w programie Excel?
Jak zamienić # błędy formuły na 0, pusty lub określony tekst w programie Excel?
Jak przekonwertować wartość logiczną prawda / fałsz na liczbę (1/0) lub tekst w programie Excel?


Policz komórki zawierające określone słowa lub znaki za pomocą funkcji LICZ.JEŻELI

Ponieważ wiemy już o znakach wieloznacznych, nadszedł czas, abyśmy nauczyli się używać formuły LICZ.JEŻELI do zliczania komórek zawierających określony znak lub słowo. Zobaczmy poniższe przykłady:

liczyć puste mniej 1

Aby policzyć chłopców w klasie, użyj wzoru:
=LICZ.JEŻELI(B2:B9;"MĘŻCZYZNA") >>> Wynik to 5
Aby policzyć liczbę imion zawierających znaki „jeff” (wartość w komórce A6), użyj formuły:
=LICZ.JEŻELI(A2:A9;"*jeff*") OR = LICZ.JEŻELI (A2: A9; „*” & A6 & „*”) >>> Wynik to 2
Aby policzyć liczbę imion zawierających literę „e”, użyj wzoru:
=COUNTIF(A2:A9,"*e*") >>> The result is 5
Aby policzyć liczbę imion, które nie zawierają litery „e”, użyj wzoru:
=LICZ.JEŻELI(A2:A9;"<>*e*") >>> Wynik to 3
Aby policzyć liczbę imion zaczynających się na literę „e”, użyj wzoru:
=LICZ.JEŻELI(A2:A9;"e*") >>> Wynik to 2
Aby policzyć liczbę imion kończących się literą „e”, użyj wzoru:
=LICZ.JEŻELI(A2:A9;"*e") >>> Wynik to 1
Aby policzyć liczbę imion z literą „m” jako trzecią literą, użyj wzoru:
=LICZ.JEŻELI(A2:A9;"??m*") >>> Wynik to 2

Policz komórki zawierające określone słowa lub znaki za pomocą kilku kliknięć

Z our Dodatek Excel instwszystkie proszę wykonać następujące czynności:

1. Idź do Kutools kartę, znajdź Wybierzi kliknij Wybierz określone komórki na liście rozwijanej.

liczyć puste mniej 1

2. w Wybierz określone komórki w oknie dialogowym wybierz zakres komórek, który chcesz policzyć, a następnie kliknij Komórka pod Typ wyboru, wybierz jeden warunek z listy rozwijanej Określony typ zgodnie z Twoimi potrzebami.

liczyć puste mniej 1

Tutaj podam dwa przykłady używania Kutools doradzaćt komórki zawierające określone słowo(a) lub znak(i).

• Aby policzyć chłopców w klasie, kliknij Równa się na liście rozwijanej i wpisz Mężczyzna w prawym polu wprowadzania lub możesz wybrać komórkę z wartością „Mężczyzna” w arkuszu, klikając liczyć puste mniej 1przycisk.

liczyć puste mniej 1

Program zwróci wynik zliczania i wybierze komórkę (komórki) spełniające kryteria. Możesz je skopiować, jeśli potrzebujesz.

• Aby policzyć liczbę imion zawierających znaki „jeff”, kliknij zawiera na liście rozwijanej i wpisz Jeff, lub zaznacz komórkę A6 w arkuszu, klikając liczyć puste mniej 1przycisk.

liczyć puste mniej 1

Program zwróci wynik zliczania i wybierze komórkę (komórki) spełniające kryteria. Możesz je skopiować, jeśli potrzebujesz.



  • Pasek Super Formula (łatwo edytować wiele wierszy tekstu i formuły); Układ do czytania (łatwe odczytywanie i edytowanie dużej liczby komórek); Wklej do filtrowanego zakresu...
  • Scal komórki / wiersze / kolumny i przechowywanie danych; Podziel zawartość komórek; Połącz zduplikowane wiersze i sumę / średnią... Zapobiegaj zduplikowanym komórkom; Porównaj zakresy...
  • Wybierz Duplikat lub Unikalny Wydziwianie; Wybierz puste wiersze (wszystkie komórki są puste); Super Find i Fuzzy Find w wielu zeszytach ćwiczeń; Losowy wybór ...
  • Dokładna kopia Wiele komórek bez zmiany odwołania do formuły; Automatyczne tworzenie odniesień do wielu arkuszy; Wstaw punktory, Pola wyboru i nie tylko ...
  • Ulubione i szybkie wstawianie formuł, Zakresy, wykresy i obrazy; Szyfruj komórki z hasłem; Utwórz listę mailingową i wysyłaj e-maile ...
  • Wyodrębnij tekst, Dodaj tekst, Usuń według pozycji, Usuń przestrzeń; Tworzenie i drukowanie podsumowań stronicowania; Konwertuj zawartość komórek i komentarze...
  • Super filtr (zapisz i zastosuj schematy filtrów do innych arkuszy); Zaawansowane sortowanie według miesiąca / tygodnia / dnia, częstotliwości i innych; Specjalny filtr pogrubieniem, kursywą ...
  • Połącz skoroszyty i arkusze robocze; Scal tabele na podstawie kluczowych kolumn; Podziel dane na wiele arkuszy; Konwersja wsadowa xls, xlsx i PDF...
  • Grupowanie tabel przestawnych według numer tygodnia, dzień tygodnia i więcej ... Pokaż odblokowane, zablokowane komórki w różnych kolorach; Podświetl komórki, które mają formułę / nazwę...
karta kte 201905
  • Włącz edycję i czytanie na kartach w programach Word, Excel, PowerPoint, Publisher, Access, Visio i Project.
  • Otwieraj i twórz wiele dokumentów w nowych kartach tego samego okna, a nie w nowych oknach.
  • Zwiększa produktywność o 50% i zmniejsza setki kliknięć myszą każdego dnia!
officetab dół
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.

Be the first to comment.