Note: The other languages of the website are Google-translated. Back to English

Policz liczbę komórek zawierających określoną liczbę znaków

Jeśli chcesz policzyć liczbę komórek zawierających określoną liczbę znaków (np. 5 znaków) w zakresie komórek, jak pokazano na zrzucie ekranu. W programie Excel funkcja LICZ.JEŻELI może Ci wyświadczyć przysługę. W tym artykule omówię, jak uzyskać liczbę komórek zawierających dokładnie x znaków lub komórki zawierające więcej niż określoną liczbę znaków.


Policz liczbę komórek zawierających dokładnie x znaków

Funkcja LICZ.JEŻELI może pomóc w uzyskaniu liczby komórek zawierających określoną liczbę znaków, ogólna składnia to:

=COUNTIF(range,"?????")
=LICZ.JEŻELI(zakres;POWT(„?”;X))
  • range: zakres komórek, które chcesz policzyć;
  • ?: Wskazuje symbol wieloznaczny pasujący do dowolnego pojedynczego znaku;
  • X: Liczba znaków, na podstawie których należy liczyć.

1. Wprowadź lub skopiuj dowolną z następujących formuł do pustej komórki, aby wyświetlić wynik:

=COUNTIF(A2:A12,"?????")
=LICZ.JEŻELI(A2:A13;POWT("?";5))

Uwagi: W pierwszej formule ????? wskazuje dowolne pięć znaków, na podstawie których chcesz liczyć; W drugiej formule POWT(“?”,5) zwróci ciąg tekstowy składający się z dokładnie 5 znaków zapytania. W tym przykładzie REPT("?",5) zwraca "?????".

2. A następnie naciśnij Wchodzę klucz, aby uzyskać wymagany wynik, patrz zrzut ekranu:


Policz liczbę komórek o długości tekstu większej niż x znaków

Jeśli chcesz uzyskać liczbę komórek, w których długość tekstu jest większa niż 15 znaków, możesz zastosować razem funkcje SUMPRODUCT, LEN i N, ogólna składnia to:

=PROD.SUMA(N(DŁ(zakres)>X))
  • range: zakres komórek, które chcesz policzyć;
  • X: Liczba znaków, na podstawie których należy liczyć.

1. Wprowadź lub skopiuj poniższą formułę do pustej komórki:

=SUMPRODUCT(N(LEN(A2:A10)>15))

2. Następnie naciśnij wchodzić klawisz, aby uzyskać wynik od razu, zobacz zrzut ekranu:


Wyjaśnienie wzoru:
  • DŁ(A2:A10): Ta funkcja LEN oblicza długość każdej komórki z wybranego zakresu i zwraca listę tablic w następujący sposób: {17;10;12;22;19;10;14;21;9}.
  • DŁ(A2:A10)>15: Ta część porównuje długość tekstu każdej komórki z określoną liczbą 15, jeśli jest większa niż 15, wyświetla TRUE, w przeciwnym razie zwraca FALSE. Otrzyma następujący wynik: {PRAWDA;FAŁSZ;FAŁSZ;PRAWDA;PRAWDA;FAŁSZ;FAŁSZ;PRAWDA;FAŁSZ}.
  • N(DŁ(A2:A10)>15): Ta funkcja N służy do konwersji TRUE i FALSE odpowiednio na 1 i 0, tak jak poniżej: {1;0;0;1;1;0;0;1;0}
  • SUMPRODUCT(N(LEN(A2:A10)>15))=SUMPRODUCT({1;0;0;1;1;0;0;1;0}): W końcu ta funkcja SUMPRODUCT zsumuje wszystkie liczby w tablicy, więc otrzymasz wynik: 4.

Zastosowana funkcja względna:

  • COUNTIF:
  • Funkcja LICZ.JEŻELI to funkcja statystyczna w programie Excel, która służy do zliczania liczby komórek spełniających kryterium.
  • SUMPRODUCT:
  • Funkcja SUMPRODUCT może służyć do mnożenia dwóch lub więcej kolumn lub tablic, a następnie do uzyskania sumy iloczynów.
  • LEN:
  • Funkcja DŁ zwraca liczbę znaków w ciągu tekstowym.
  • N:
  • Funkcja N konwertuje wartość na liczbę.

Więcej artykułów:

  • Policz liczbę komórek nierówną wielu wartościom w Excelu
  • W programie Excel możesz łatwo uzyskać liczbę komórek nierówną określonej wartości za pomocą funkcji LICZ.JEŻELI, ale czy kiedykolwiek próbowałeś policzyć komórki, które nie są równe wielu wartościom? Na przykład chcę uzyskać całkowitą liczbę produktów w kolumnie A, ale wykluczyć określone elementy w C4: C6, jak pokazano na zrzucie ekranu. W tym artykule przedstawię kilka formuł rozwiązywania tego zadania w programie Excel.
  • Policz Liczba komórek zawiera wartości liczbowe lub nieliczbowe
  • Jeśli masz zakres danych, który zawiera zarówno wartości liczbowe, jak i nienumeryczne, a teraz możesz policzyć liczbę komórek numerycznych lub nienumerycznych, jak pokazano na poniższym zrzucie ekranu. W tym artykule omówię niektóre formuły rozwiązywania tego zadania w programie Excel.

Najlepsze narzędzia biurowe

Kutools dla programu Excel - pomaga wyróżnić się z tłumu

Chcesz szybko i perfekcyjnie zakończyć swoją codzienną pracę? Kutools dla programu Excel oferuje 300 zaawansowanych zaawansowanych funkcji (Łącz skoroszyty, sumuj według koloru, dziel zawartość komórek, konwertuj daty itd.) i oszczędzaj 80% czasu.

  • Zaprojektowany dla 1500 scenariuszy pracy, pomaga rozwiązać 80% problemów z Excelem.
  • Zmniejsz tysiące kliknięć klawiatury i myszy każdego dnia, odciąż zmęczone oczy i dłonie.
  • Zostań ekspertem Excela w 3 minuty. Nie musisz już pamiętać żadnych bolesnych formuł i kodów VBA.
  • 30-dniowy nieograniczony bezpłatny okres próbny. 60-dniowa gwarancja zwrotu pieniędzy. Bezpłatna aktualizacja i wsparcie przez 2 lata.
Wstążka programu Excel (z zainstalowanym Kutools dla programu Excel)

Karta Office - Włącz czytanie i edycję na kartach w Microsoft Office (w tym Excel)

  • Jedna sekunda, aby przełączać się między dziesiątkami otwartych dokumentów!
  • Zmniejsz liczbę kliknięć myszą każdego dnia, pożegnaj się z dłonią myszy.
  • Zwiększa produktywność o 50% podczas przeglądania i edytowania wielu dokumentów.
  • Wprowadza wydajne zakładki do pakietu Office (w tym Excel), podobnie jak Chrome, Firefox i nowy Internet Explorer.
Zrzut ekranu programu Excel (z zainstalowaną kartą Office)
Sortuj komentarze według
Komentarze (0)
Brak ocen. Oceń jako pierwszy!
Nie ma tu jeszcze żadnych komentarzy
Zostaw swój komentarz
Publikowanie jako gość
×
Oceń ten post:
0   Postacie
Sugerowane lokalizacje

Bądż na bieżąco

Prawa autorskie © 2009 - www.extendoffice.com. | Wszelkie prawa zastrzeżone. Zasilany przez ExtendOffice, | Mapa strony
Microsoft i logo Office są znakami towarowymi lub zastrzeżonymi znakami towarowymi Microsoft Corporation w Stanach Zjednoczonych i / lub innych krajach.
Chronione przez Sectigo SSL