Przejdź do głównej zawartości

Funkcja ISERR Excel

Funkcja ISERR zwraca TRUE dla dowolnego typu błędu (z wyjątkiem #N/A) i FALSE w przeciwnym razie.

funkcja iserr 1


Składnia

=ISERR(value)


Argumenty

  • wartość (wymagane): Wartość, którą chcesz przetestować, jeśli jest to jakikolwiek błąd poza #N/D.

Wartość zwracana

Funkcja ISERR zwraca PRAWDA lub FAŁSZ.


Uwagi dotyczące funkcji

  • ISERR jest często używany z funkcją JEŻELI do wyświetlania niestandardowego komunikatu lub wykonywania innych obliczeń w przypadku znalezienia błędu, na przykład =JEŻELI(CZY.BŁĄD(A1);"wiadomość"), =SUMA(--CZY.BŁĄD(A1:A10)).

Przykład

Jako przykład weź poniższą tabelę. Aby przetestować wartości wymienione w tabeli, jeśli są to jakiekolwiek typy błędów, ale #N/A, skopiuj lub wprowadź poniższą formułę w górnej komórce, naciśnij Wchodzę aby uzyskać wynik, a następnie przeciągnij uchwyt wypełniania (w prawym dolnym rogu komórki wynikowej) w dół, aby zastosować formułę do komórek poniżej.

=CZY.PORR(B3)

funkcja iserr 2


Powiązane funkcje

Funkcja Excel ISBLANK

Funkcja CZY.PUSTE zwraca PRAWDA, jeśli komórka jest pusta lub pusta, a FAŁSZ w przeciwnym razie.

Funkcja CZY.BŁĄD programu Excel

Funkcja ISERROR zwraca TRUE dla dowolnego typu błędu i FALSE w przeciwnym razie.

Funkcja ISLOGICZNA Excel

Funkcja CZY.LOGICZNE zwraca PRAWDA dla wartości logicznej i FAŁSZ w przeciwnym razie.

Funkcja ISNA Excel

Funkcja ISNONTEKST zwraca PRAWDA dla wartości błędu #N/D, a FAŁSZ w przeciwnym razie.

Funkcja Excel ISNONTEXT

Funkcja ISNONTEXT zwraca TRUE dla wartości, która nie jest tekstem, a FALSE w przeciwnym razie.

Funkcja ISNUMBER w Excelu

Funkcja CZY.LICZBA zwraca PRAWDA dla liczby i FAŁSZ w przeciwnym razie.

Funkcja ISREF Excel

Funkcja ISREF zwraca TRUE dla odwołania i FALSE w przeciwnym razie.

Funkcja CZY.TEKST programu Excel

Funkcja CZY.TEKST zwraca PRAWDA dla wartości tekstowej i FAŁSZ w przeciwnym razie.


Najlepsze narzędzia biurowe

Kutools dla programu Excel - pomaga wyróżnić się z tłumu

Popularne funkcje: Znajdź, wyróżnij lub zidentyfikuj duplikaty  |  Usuń puste wiersze  |  Łącz kolumny lub komórki bez utraty danych  |  Okrągły bez wzoru ...
Super VLookup: Wiele kryteriów  |  Wiele wartości  |  W wielu arkuszach  |  Wyszukiwanie rozmyte...
Adw. Lista rozwijana: Łatwa lista rozwijana  |  Zależna lista rozwijana  |  Lista rozwijana wielokrotnego wyboru...
Menedżer kolumn: Dodaj określoną liczbę kolumn  |  Przesuń kolumny  |  Przełącz stan widoczności ukrytych kolumn  Porównaj kolumny z Wybierz Te same i różne komórki ...
Polecane funkcje: Fokus siatki  |  Widok projektu  |  Duży pasek formuły  |  Menedżer skoroszytów i arkuszy | Biblioteka zasobów (Automatyczny tekst)  |  Selektor dat  |  Połącz arkusze  |  Szyfruj/odszyfruj komórki  |  Wysyłaj e-maile według listy  |  Super filtr  |  Specjalny filtr (filtruj pogrubienie/kursywa/przekreślenie...) ...
15 najlepszych zestawów narzędzi12 Tekst Tools (Dodaj tekst, Usuń znaki ...)  |  50 + Wykres rodzaje (Wykres Gantta ...)  |  40+ Praktyczne Wzory (Oblicz wiek na podstawie urodzin ...)  |  19 Wprowadzenie Tools (Wstaw kod QR, Wstaw obraz ze ścieżki ...)  |  12 Konwersja Tools (Liczby na słowa, Przeliczanie walut ...)  |  7 Połącz i podziel Tools (Zaawansowane wiersze łączenia, Podziel komórki Excela ...)  |  ... i więcej

Kutools dla programu Excel oferuje ponad 300 funkcji, Pewność, że to, czego potrzebujesz, jest w zasięgu jednego kliknięcia...


Karta Office - Włącz czytanie i edycję na kartach w Microsoft Office (w tym Excel)

  • Jedna sekunda, aby przełączać się między dziesiątkami otwartych dokumentów!
  • Zmniejsz liczbę kliknięć myszą każdego dnia, pożegnaj się z dłonią myszy.
  • Zwiększa produktywność o 50% podczas przeglądania i edytowania wielu dokumentów.
  • Wprowadza wydajne karty do pakietu Office (w tym programu Excel), podobnie jak przeglądarki Chrome, Edge i Firefox.
Comments (0)
No ratings yet. Be the first to rate!
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations