Note: The other languages of the website are Google-translated. Back to English

Pobierz ostatnią wartość tekstową w kolumnie

Załóżmy, że masz listę danych zawierającą liczby, daty, tekst, błędy i wartości logiczne (PRAWDA i FAŁSZ), aby uzyskać ostatnią wartość tekstową z listy, formułę opartą na INDEKS i MATCH funkcje mogą wyświadczyć ci przysługę.

pobierz ostatnią wartość tekstową w kolumnie 1

Jak pobrać ostatnią wartość tekstową na liście?

Aby odzyskać ostatnia wartość tekstowa na liście jak pokazano powyżej, funkcje INDEKS i PODAJ.POZYCJĘ pomogą Ci w ten sposób: Funkcja PODAJ.POZYCJĘ, która została ustawiona na wykonanie dokładnego dopasowania, lokalizuje pozycję ostatniej wartości tekstowej. INDEX następnie pobierze wartość z tej pozycji.

Ogólna składnia

=INDEX(range,MATCH("*",range,-1))

√ Uwaga: wartość wyszukiwania „*” może pasować do dowolnej liczby znaków. Nie dopasowuje błędów, liczb ani wartości logicznych (TURE i FALSE).

  • zakres: Lista (zakres jednokolumnowy), z której ma zostać zwrócona ostatnia wartość tekstowa.

Aby odzyskać ostatnia wartość tekstowa na liście, skopiuj lub wprowadź poniższą formułę w komórce E4 i naciśnij Wchodzę aby uzyskać wynik:

=INDEKS(zasięg,MECZ("*",zasięg, -1))

pobierz ostatnią wartość tekstową w kolumnie 2

Wyjaśnienie formuły

=INDEX(B4:B15,MATCH("*",B4:B15,-1))

  • PODAJ.POZYCJĘ("*",B4:B15,-1): Typ dopasowania -1 wymusza zwrócenie przez funkcję MATCH pozycji ostatniej wartości tekstowej w zakresie B4: B15. Tak więc funkcja zwróci 8.
  • INDEKS(B4: B15,PODAJ.POZYCJĘ("*",B4:B15,-1)) = INDEKS(B4: B15,8): Funkcja INDEX zwraca następnie 8th wartość z zakresu B4: B15, który jest Karta Office.

Powiązane funkcje

Funkcja Excel INDEKS

Funkcja Excel INDEX zwraca wyświetlaną wartość na podstawie podanej pozycji z zakresu lub tablicy.

Funkcja Excel MATCH

Funkcja Excel PODAJ.POZYCJĘ wyszukuje określoną wartość w zakresie komórek i zwraca względną pozycję wartości.


Powiązane formuły

Pobierz pierwszą wartość tekstową w kolumnie

Aby pobrać pierwszą wartość tekstową z zakresu jednokolumnowego, możesz użyć formuły opartej na funkcjach INDEKS i PODAJ.POZYCJĘ, a także formuły opartej na funkcji WYSZUKAJ.PIONOWO.

Uzyskaj pierwszą niepustą wartość w kolumnie lub wierszu

Aby pobrać pierwszą wartość (pierwszą komórkę, która nie jest pusta, ignorując błędy) z zakresu jednokolumnowego lub jednowierszowego, możesz użyć formuły opartej na funkcjach INDEKS i PODAJ.POZYCJĘ. Jeśli jednak nie chcesz ignorować błędów z zakresu, możesz dodać funkcję ISBLANK do powyższej formuły.

Pobierz informacje związane z najniższymi wartościami n

Aby pobrać dane odpowiadające najmniejszej, drugiej najmniejszej lub n-tej najmniejszej wartości na liście, tabeli lub wierszu w programie Excel, możesz użyć formuły INDEKS i PODAJ.POZYCJĘ wraz z funkcją MAŁY.

Uzyskaj informacje odpowiadające maksymalnej wartości

Aby pobrać dane odpowiadające maksymalnej wartości na liście, tabeli lub wierszu w programie Excel, możesz użyć formuły INDEKS i DOPASUJ wraz z funkcją MAX.


Najlepsze narzędzia biurowe

Kutools dla programu Excel - pomaga wyróżnić się z tłumu

Chcesz szybko i perfekcyjnie zakończyć swoją codzienną pracę? Kutools dla programu Excel oferuje 300 zaawansowanych zaawansowanych funkcji (Łącz skoroszyty, sumuj według koloru, dziel zawartość komórek, konwertuj daty itd.) i oszczędzaj 80% czasu.

  • Zaprojektowany dla 1500 scenariuszy pracy, pomaga rozwiązać 80% problemów z Excelem.
  • Zmniejsz tysiące kliknięć klawiatury i myszy każdego dnia, odciąż zmęczone oczy i dłonie.
  • Zostań ekspertem Excela w 3 minuty. Nie musisz już pamiętać żadnych bolesnych formuł i kodów VBA.
  • 30-dniowy nieograniczony bezpłatny okres próbny. 60-dniowa gwarancja zwrotu pieniędzy. Bezpłatna aktualizacja i wsparcie przez 2 lata.
Wstążka programu Excel (z zainstalowanym Kutools dla programu Excel)

Karta Office - Włącz czytanie i edycję na kartach w Microsoft Office (w tym Excel)

  • Jedna sekunda, aby przełączać się między dziesiątkami otwartych dokumentów!
  • Zmniejsz liczbę kliknięć myszą każdego dnia, pożegnaj się z dłonią myszy.
  • Zwiększa produktywność o 50% podczas przeglądania i edytowania wielu dokumentów.
  • Wprowadza wydajne zakładki do pakietu Office (w tym Excel), podobnie jak Chrome, Firefox i nowy Internet Explorer.
Zrzut ekranu programu Excel (z zainstalowaną kartą Office)
Sortuj komentarze według
Komentarze (0)
Brak ocen. Oceń jako pierwszy!
Nie ma tu jeszcze żadnych komentarzy
Zostaw swój komentarz
Publikowanie jako gość
×
Oceń ten post:
0   Postacie
Sugerowane lokalizacje

Bądż na bieżąco

Prawa autorskie © 2009 - www.extendoffice.com. | Wszelkie prawa zastrzeżone. Zasilany przez ExtendOffice, | Mapa strony
Microsoft i logo Office są znakami towarowymi lub zastrzeżonymi znakami towarowymi Microsoft Corporation w Stanach Zjednoczonych i / lub innych krajach.
Chronione przez Sectigo SSL